¿Debería actualizar mi sitio a Joomla 2.5?

Escrito por Isidro Baquero.

Joomla! 1.5 dejará de tener soporte en abril de 2012 - Copyright Themeforest.comAnte el inminente lanzamiento de Joomla 2.5 GA (General Availability, o lo que es lo mismo, versión estable), los amigos de Themepartner han elaborado una excelente infografía para ayudarnos a decidir si es el momento de actualizar a Joomla 2.5 o no.

Desde Gnumla hemos querido aportar una vez más nuestro granito de arena y permitir a la comunidad de habla hispana beneficiarse de este excelente aporte, y hemos traducido la infografía. Además, la acompañamos de algunos datos adicionales para completar totalmente la información.

NOTA: La imagen adjunta es una captura de la infografía, y no puede ser usada sin permiso expreso de Themepartner.com

Algunas consideraciones antes de leer la infografía:

  • La actualización desde Joomla 1.7 a Joomla 2.5 podrá hacerse con un par de clics desde el gestor de extensiones, directamente desde el backend de vuestros sitios, y sin necesidad de acceder por FTP.
  • El 99,9% de las extensiones y plantillas que actualmente funcionan en Joomla 1.7 deberían funcionar en Joomla 2.5, incluso aunque sus desarrolladores no hayan actualizado los paquetes específicamente. Esto es así porque, en realidad, Joomla 2.5 no es más que una versión estable de Joomla 1.7 con algunas mejoras. Es la culminación del ciclo de desarrollo iniciado hace algo más de un año por Joomla 1.6. Sergio Iglesias nos lo explica muy bien en su blog.
  • Para actualizar desde Joomla 1.5 lo que tendremos que hacer en realidad será una migración, ya que Joomla 1.6/1.7/2.5 tienen una base de código totalmente distinta a su predecesora. Para ello existe jUpgrade, desarrollada por Matías Aguirre. En este artículo de la documentación oficial tenéis más datos (en inglés).
  • Y los que aún usen Joomla 1.0 aún lo tienen más difícil, pues tendrán que hacer una primera migración de Joomla 1.0 a Joomla 1.5 y, posteriormente, una segunda desde Joomla 1.5 a Joomla 2.5. Más información aquí, o bien aquí (una vez más, en inglés, me temo).
  • El soporte oficial para Joomla 1.5 finaliza en abril de 2012, esto es, dentro de apenas 3 meses. Esto significa que el equipo de desarrollo de Joomla dejará de proporcionar paquetes de actualización del software, por lo que al cabo de varios meses el paquete será casi con toda seguridad inseguro (siempre se descubren nuevas vulnerabilidades con el paso del tiempo).
  • Joomla 2.5 será una versión con soporte de larga duración, lo que significa que estará mantenida por el Proyecto Joomla durante un mínimo de 18 meses. Un argumento de peso a la hora de decidir qué plataforma usar para nuevos proyectos.

Aclarados estos puntos, veamos la infografía sin más preámbulos. ¡Que la disfrutéis!

¿Dbería actualizar a Joomla 2.5? Infografía

 

Infografía original de Themepartner.com

Sobre el autor
Isidro Baquero
Author: Isidro Baquero

Desde 2008 ha trabajado como freelance, fundamentalmente desarrollando sitios web basados en Joomla, aunque también como webmaster, gestor de comunidades o traductor del inglés al español de aplicaciones de software. Actualmente forma parte del equipo de SobiPro en Sigsiu.NET, donde desempeña labores de soporte, documentación, pruebas de software y traducción al español.

::- Contactar -::


Comentarios  

 
-1 #11 Diego 09-03-2012 18:49
me gusto lo de la limonada
Citar
 
 
0 #12 Isidro Baquero 19-03-2012 01:08
Saludos.

Entiendo las dudas y miedos que muchos expresáis, aunque voy a tratar de mostraros mi punto de vista al respecto.

Desde luego, conociendo bien como conozco el modo de actualización de Joomla 1.5, puedo entender que muchos os quejéis de que no sea "tan fácil como Wordpress". Y más aún si analizamos el tema de la migración de la 1.5 a la 2.5 (o 1.6/1.7 los que la hiciérais antes). Hasta ahí toda mi comprensión.

Los que hayáis utilizado Joomla 1.6 desde el principio, habréis podido actualizar vuestros sitios fácilmente primero a la 1.7, y más tarde la 1.7 a la 2.5, con apenas unos clics. Es cierto que algunas de las actualizaciones dieron algún pequeño problema, pero rápidamente salió un parche que lo solucionó. Y esta estrategia iniciada con Joomla 1.6 de actualizaciones con un clic será la tónica predominante a partir de ahora en Joomla. Es posible que el paso de la 2.5 a la 3.x requiera algo más que un simple clic en el gestor de actualizaciones , pero desde luego no será algo tan farragoso como es ahora mismo pasar de la 1.5 a la 2.5.

En cuanto a que 18 meses son pocos... bueno, aquí no hay más remedio que llegar a un punto medio. Me explico. Por un lado, tenemos a los usuarios, que desde luego quieren las menos complicaciones posibles. Y por otro, tenemos a los desarrolladores , tanto los del core de Joomla como los de extensiones. Estos últimos viven siempre "en el filo de la navaja", tratando de incorporar siempre las últimas tecnologías a sus desarrollos, para que tanto Joomla como sus extensiones estén a la vanguardia de la tecnología web. Por tanto, entre los más innovadores hay siempre una tendencia a usar lo último de lo último, y si por ellos fuera, cada 3 meses habría grandes innovaciones... de hecho esto es exactamente lo que pasa en la JPlatform; una nueva versión cada 3 meses con grandes avances. El ciclo de desarrollo del CMS es más conservador, y aún así se ha acelerado muchísimo: de los 3 años que se tardaba antes, ahora tenemos una nueva versión menor cada 6 meses, y una mayor cada 18.

Otro factor a tener en cuenta es la velocidad de vértigo a la que evoluciona el mundo web. Lo que hace un año era la gran novedad, hoy ya se está quedando desfasado, si es que no lo está del todo. 18 meses pueden ser pocos en la industria del automóvil, pero no en internet. Por ejemplo, algunas funciones de Joomla 1.5 están basadas específicamente en PHP5.2 (oficialmente lanzado en 2006), y esta versión de PHP dejó de ser soportada por sus desarrolladores hace meses.

Amigos, como dicen en mi tierra "no se puede hacer una tortilla sin romper algunos huevos". Para que el CMS siga evolucionando, en algún momento hay que dejar atrás las trabas que imponen las versiones antiguas. Pongamos por ejemplo Joomla 2.5. Esta versión no es más que una versión estable y mejorada de la 1.6, liberada en enero de 2011. Por tanto, aunque su soporte es de 18 meses desde su lanzamiento, en realidad la base tecnológica de Joomla 2.5 data de principios de 2011... o de antes, pues el desarrollo no se hace de la noche a la mañana. Siendo generosos, podríamos decir que Joomla 2.5 se desarrolló con tecnología de mediados de 2010. Cuando llegue al final de su ciclo de vida a mediados de 2013, dicho ciclo habrá sido de nada menos que ¡3 años! Eso es una barbaridad.
Citar
 
 
0 #13 mavaflocor 20-04-2012 23:37
osea que pasara en abril cuando joomla 1.5 deje de funcionar..
la web que esta diseñada con joomla 1.5 ya no funcionara, es decir me aparecerá ese mensaj que dice, internet explore no puede mostrar la pagina... o unicamente ya no abran modulos para 1.5
por favor expliqueme
Citar
 
 
0 #14 Isidro Baquero 21-04-2012 11:47
Hola mavaflocor.

No, Joomla 1.5 no dejará de funcionar en absoluto. Simplemente dejará de recibir soporte, esto es, dejarán de sacarse "parches" para corregir problemas de seguridad que se detecten.

Por otro lado, parece que finalmente el soporte se ampliará hasta septiembre de este año, por lo que aún se tiene algo más de margen.

Un saludo
Citar
 
 
0 #15 Luis Alberto 21-04-2012 18:01
Cito a Isidro B.:
Hola mavaflocor.

No, Joomla 1.5 no dejará de funcionar en absoluto. Simplemente dejará de recibir soporte, esto es, dejarán de sacarse "parches" para corregir problemas de seguridad que se detecten.

Por otro lado, parece que finalmente el soporte se ampliará hasta septiembre de este año, por lo que aún se tiene algo más de margen.

Un saludo


Es bueno saber esto Isidro B. aunque por otro lado he encontrado la extencion jsecure que parece ser algo muy prometedor para la seguridad de nuestro joomla 1.5.26 o de cualquier otro joomla y sin embargo si se requiere algo mas pues tambien esta RSfirewall aunque su precio me parece execible aun siendo de licencia ilimitada si uno se dedica al desarrollo de sitios web para terceros RSfirewall noto que si es algo cara pero en si joomla 1.5 y jsecure estoy seguro podran mantener mi sitio activo por mucho tiempo.
Citar
 
 
0 #16 Carlos M. Cámara 21-04-2012 18:55
Me parece un tremendo error Luis Alberto, la seguridad web no puede confiarse a un sólo componente, la seguridad web es un proceso en el que todas las partes de la cadena deben verse implicadas y es tan frágil que un eslabón débil hace que la cadena se rompa y tu sitio sea inseguro.

Un sitio con Joomla! 1.5.26 a partir de que cese el soporte de seguridad será inseguro si no hay alguien encargado de vigilar posibles vulenrabilidade s y corregirlas. Tener una extensión de Firewall como Admin Tools o las que citas en tu comentario, no te garantiza, ni mucho menos, un sitio seguro a partir del cese del soporte del proyecto Joomla!.
Citar
 

Escribir un comentario

REGLAS APLICABLES A LOS MENSAJES
  • Los comentarios serán publicados una vez que hayan sido comprobados y aprobados por un administrador del sitio.
  • No están permitidos comentarios injuriosos o amenazadores.
  • No está permitido hacer spam.
  • Los enlaces que no vayan a sitios oficiales Joomla! o que no estén relacionados con el mensaje serán editados.